aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-03-15 17:32:28 +0100
committerMax Kellermann <max@duempel.org>2009-03-15 17:32:28 +0100
commite1189712f9979f2d4470f7f5f021ebc08dff59a3 (patch)
treeea3f1b11927fa482e86adb57b2f510d47f780938 /Makefile.am
parente62580db0bab0650f088f9f45c66657d18dfb679 (diff)
downloadmpd-e1189712f9979f2d4470f7f5f021ebc08dff59a3.tar.gz
mpd-e1189712f9979f2d4470f7f5f021ebc08dff59a3.tar.xz
mpd-e1189712f9979f2d4470f7f5f021ebc08dff59a3.zip
Makefile.am: added documentation upload target
This "upload" target uploads generated documentation to http://www.musicpd.org/doc/, and works only for my user account.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index fa2efb7d6..d25703b1a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -676,6 +676,14 @@ install-data-local: doc/api/html/index.html
doc/api/html/*.png doc/api/html/*.gif \
$(DESTDIR)$(docdir)/api/html
+upload: $(DOCBOOK_HTML) doc/api/html/index.html
+ rsync -vpruz --delete doc/ cirrus@www.musicpd.org:/var/www/musicpd.org/www/doc/ \
+ --chmod=Dug+rwx,Do+rx,Fug+rw,Fo+r \
+ --include=protocol --include=protocol/** \
+ --include=user --include=user/** \
+ --include=api --include=api/** \
+ --exclude=*
+
endif