aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-03-15 03:32:34 +0100
committerMax Kellermann <max@duempel.org>2009-03-15 03:32:34 +0100
commite62580db0bab0650f088f9f45c66657d18dfb679 (patch)
tree19c0deec7b75ea7fe2513c674c7de3fe2647fa7c /Makefile.am
parent565afefc66b7753ed27f6b7febaf32667c38c44a (diff)
downloadmpd-e62580db0bab0650f088f9f45c66657d18dfb679.tar.gz
mpd-e62580db0bab0650f088f9f45c66657d18dfb679.tar.xz
mpd-e62580db0bab0650f088f9f45c66657d18dfb679.zip
httpd: new output plugin to replace "shout"
Let's get rid of the "shout" plugin, and the awfully complicated icecast daemon setup! MPD can do better if it's doing the HTTP server stuff on its own. This new plugin has several advantages: - easier to set up - only one daemon, no password settings, no mount settings - MPD controls the encoder and thus already knows the packet boundaries - icecast has to parse them - MPD doesn't bother to encode data while nobody is listening This implementation is very experimental (no header parsing, ignores request URI, no icy-metadata, ...). It should be able to suport several encoders in parallel in the future (with different bit rates, different codec, ...), to make MPD the perfect streaming server. Once MPD gets multi-player support, we can even mount several different radio stations on one server.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f585ca62e..fa2efb7d6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -94,6 +94,8 @@ mpd_headers = \
src/chunk.h \
src/path.h \
src/mapper.h \
+ src/output/httpd_client.h \
+ src/output/httpd_internal.h \
src/page.h \
src/pcm_buffer.h \
src/pcm_utils.h \
@@ -511,6 +513,12 @@ if HAVE_SHOUT
OUTPUT_SRC += src/output/shout_plugin.c
endif
+if ENABLE_HTTPD_OUTPUT
+OUTPUT_SRC += \
+ src/output/httpd_client.c \
+ src/output/httpd_output_plugin.c
+endif
+
#
# Sparse code analysis
@@ -606,6 +614,9 @@ test_run_output_SOURCES = test/run_output.c \
src/conf.c src/buffer2array.c src/utils.c src/log.c \
src/audio_parser.c \
src/timer.c \
+ src/fifo_buffer.c \
+ src/page.c \
+ src/socket_util.c \
src/output_init.c src/output_list.c \
$(ENCODER_SRC) \
src/mixer_api.c \