aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-02-18 22:27:55 +0100
committerMax Kellermann <max@duempel.org>2009-02-18 22:27:55 +0100
commit76dc9ac5f9437268bc167bc681168ef2c1f7420b (patch)
tree5a051bcd63d0620d607afd6cc3b1816b7d5c895a /Makefile.am
parent54387d14516c15bcdf938cafe16c627570354587 (diff)
downloadmpd-76dc9ac5f9437268bc167bc681168ef2c1f7420b.tar.gz
mpd-76dc9ac5f9437268bc167bc681168ef2c1f7420b.tar.xz
mpd-76dc9ac5f9437268bc167bc681168ef2c1f7420b.zip
test: added command line test program for pcm_volume.c
This program is a simple utility for debugging and benchmarking the software volume code.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index f39793efb..22bb8014f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,7 +7,6 @@ EXTRA_DIST = $(doc_DATA) autogen.sh \
$(wildcard scripts/*.sh) scripts/mpd.spec \
.gitignore
-
AM_CFLAGS = -I$(srcdir)/src $(GLIB_CFLAGS)
AM_LDFLAGS = $(GLIB_LIBS)
@@ -18,7 +17,11 @@ AM_LDFLAGS = $(GLIB_LIBS)
if ENABLE_TEST
-noinst_PROGRAMS =
+noinst_PROGRAMS = test/software_volume
+
+test_software_volume_SOURCES = test/software_volume.c \
+ src/audio_parser.c \
+ src/pcm_volume.c
endif