aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-02-18 19:27:05 +0100
committerMax Kellermann <max@duempel.org>2009-02-18 19:27:05 +0100
commit54387d14516c15bcdf938cafe16c627570354587 (patch)
treec994e181bb0fa0049e60a9cd698fc6984d7c3cbc /Makefile.am
parentfcf65de46bb8987c1237d7114d3b8e411b8f0d2a (diff)
downloadmpd-54387d14516c15bcdf938cafe16c627570354587.tar.gz
mpd-54387d14516c15bcdf938cafe16c627570354587.tar.xz
mpd-54387d14516c15bcdf938cafe16c627570354587.zip
configure.ac: added switch for test programs
The switch syntax is "--enable-test". There are no test programs yet.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ede4f6a0d..f39793efb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,6 +7,22 @@ EXTRA_DIST = $(doc_DATA) autogen.sh \
$(wildcard scripts/*.sh) scripts/mpd.spec \
.gitignore
+
+AM_CFLAGS = -I$(srcdir)/src $(GLIB_CFLAGS)
+AM_LDFLAGS = $(GLIB_LIBS)
+
+
+#
+# Test programs
+#
+
+if ENABLE_TEST
+
+noinst_PROGRAMS =
+
+endif
+
+
sparse-check test:
$(MAKE) -C src $@