aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2012-03-21 19:08:32 +0100
committerMax Kellermann <max@duempel.org>2012-03-21 19:08:32 +0100
commit62218fe59d14cca29e15e8c687a568c850cb6003 (patch)
treeca58bd37cf6cf7181193e58a1496f2550f7d35bd /Makefile.am
parent95d9bb6dfc1b90135c66b19d83eb17436908e3e8 (diff)
downloadmpd-62218fe59d14cca29e15e8c687a568c850cb6003.tar.gz
mpd-62218fe59d14cca29e15e8c687a568c850cb6003.tar.xz
mpd-62218fe59d14cca29e15e8c687a568c850cb6003.zip
test: add unit test for util/byte_reverse.c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4ac5d1a39..3115ceb08 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -975,6 +975,7 @@ sparse-check:
if ENABLE_TEST
C_TESTS = \
+ test/test_byte_reverse \
test/test_pcm \
test/test_queue_priority
@@ -1262,6 +1263,13 @@ test_run_inotify_SOURCES = test/run_inotify.c \
test_run_inotify_LDADD = $(GLIB_LIBS)
endif
+test_test_byte_reverse_SOURCES = \
+ test/test_glib_compat.h \
+ test/test_byte_reverse.c
+test_test_byte_reverse_LDADD = \
+ libutil.a \
+ $(GLIB_LIBS)
+
test_test_pcm_SOURCES = \
test/test_glib_compat.h \
test/test_pcm_dither.c \