aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2011-10-09 13:22:08 +0200
committerMax Kellermann <max@duempel.org>2011-10-10 10:24:05 +0200
commit572d8d0cc486dce64c0f6239cc27598068c1085d (patch)
tree875798952cdb2175b52e0346dc38e10a1a8b5a15 /Makefile.am
parentc9a57d354d87493d6bba7675b38dcf9ac468b11b (diff)
downloadmpd-572d8d0cc486dce64c0f6239cc27598068c1085d.tar.gz
mpd-572d8d0cc486dce64c0f6239cc27598068c1085d.tar.xz
mpd-572d8d0cc486dce64c0f6239cc27598068c1085d.zip
test: add unit test for the PCM library
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8d30ea655..b86a5557c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -937,6 +937,7 @@ sparse-check:
if ENABLE_TEST
C_TESTS = \
+ test/test_pcm \
test/test_queue_priority
TESTS = $(C_TESTS)
@@ -1193,6 +1194,17 @@ test_run_inotify_SOURCES = test/run_inotify.c \
test_run_inotify_LDADD = $(GLIB_LIBS)
endif
+test_test_pcm_SOURCES = \
+ test/test_pcm_dither.c \
+ test/test_pcm_pack.c \
+ test/test_pcm_channels.c \
+ test/test_pcm_byteswap.c \
+ test/test_pcm_all.h \
+ test/test_pcm_main.c
+test_test_pcm_LDADD = \
+ $(PCM_LIBS) \
+ $(GLIB_LIBS)
+
test_test_queue_priority_SOURCES = \
src/queue.c \
test/test_queue_priority.c