aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2011-10-10 08:17:39 +0200
committerMax Kellermann <max@duempel.org>2011-10-10 10:13:43 +0200
commitc9a57d354d87493d6bba7675b38dcf9ac468b11b (patch)
tree6f1d650e95d3b01e4c9ab8b87ee22a997b728b19 /Makefile.am
parent52b77f6e311c415279cff75a9af92ee9e62e5316 (diff)
downloadmpd-c9a57d354d87493d6bba7675b38dcf9ac468b11b.tar.gz
mpd-c9a57d354d87493d6bba7675b38dcf9ac468b11b.tar.xz
mpd-c9a57d354d87493d6bba7675b38dcf9ac468b11b.zip
pcm_buffer: un-inline pcm_buffer_get()
This function is too complex for being inlined everywhere.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f56b1f9aa..8d30ea655 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -369,7 +369,7 @@ endif
# PCM library
libpcm_a_SOURCES = \
- src/pcm_buffer.h \
+ src/pcm_buffer.c src/pcm_buffer.h \
src/pcm_convert.c src/pcm_convert.h \
src/pcm_volume.c src/pcm_volume.h \
src/pcm_mix.c src/pcm_mix.h \
@@ -1014,6 +1014,7 @@ endif
test_run_decoder_LDADD = \
$(DECODER_LIBS) \
+ libpcm.a \
$(INPUT_LIBS) \
$(ARCHIVE_LIBS) \
$(TAG_LIBS) \
@@ -1033,6 +1034,7 @@ test_run_decoder_SOURCES = test/run_decoder.c \
test_read_tags_LDADD = \
$(DECODER_LIBS) \
+ libpcm.a \
$(INPUT_LIBS) \
$(ARCHIVE_LIBS) \
$(TAG_LIBS) \
@@ -1094,6 +1096,7 @@ test_run_encoder_SOURCES = test/run_encoder.c \
src/audio_parser.c
test_run_encoder_LDADD = \
$(ENCODER_LIBS) \
+ libpcm.a \
$(TAG_LIBS) \
$(GLIB_LIBS)
endif
@@ -1158,6 +1161,7 @@ test_run_output_SOURCES = test/run_output.c \
src/server_socket.c
test_read_mixer_LDADD = \
+ libpcm.a \
libmixer_plugins.a \
$(OUTPUT_LIBS) \
$(GLIB_LIBS)