aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-02-25 17:12:14 +0100
committerMax Kellermann <max@duempel.org>2009-02-25 17:12:14 +0100
commit4726c7f709af4d0998b042fa74e1860953898458 (patch)
treedeb051a6a9656bee7ddd69456f10406dfe423a6e /Makefile.am
parente0e92e050e2de04ec92f782fc5af76b728f47404 (diff)
downloadmpd-4726c7f709af4d0998b042fa74e1860953898458.tar.gz
mpd-4726c7f709af4d0998b042fa74e1860953898458.tar.xz
mpd-4726c7f709af4d0998b042fa74e1860953898458.zip
test: added encoder test program
Added a command line program which runs an encoder plugin.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index fee0b18fc..11dab9892 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -504,6 +504,7 @@ if ENABLE_TEST
noinst_PROGRAMS = \
test/run_decoder \
+ test/run_encoder \
test/software_volume
test_run_decoder_CPPFLAGS = $(AM_CPPFLAGS) \
@@ -521,6 +522,14 @@ test_run_decoder_SOURCES = test/run_decoder.c \
$(INPUT_SRC) \
$(DECODER_SRC)
+test_run_encoder_SOURCES = test/run_encoder.c \
+ src/conf.c src/buffer2array.c \
+ src/utils.c \
+ src/audio_parser.c \
+ $(ENCODER_SRC)
+test_run_encoder_LDADD = $(MPD_LIBS) \
+ $(ENCODER_LIBS)
+
test_software_volume_SOURCES = test/software_volume.c \
src/audio_parser.c \
src/pcm_volume.c