aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-02-25 17:09:09 +0100
committerMax Kellermann <max@duempel.org>2009-02-25 17:09:09 +0100
commite0e92e050e2de04ec92f782fc5af76b728f47404 (patch)
tree5edcf5d13bc905f7e0955cbfbba1d02a042dd6e5 /Makefile.am
parentbdb3129f18cc42dce09984108801937512667209 (diff)
downloadmpd-e0e92e050e2de04ec92f782fc5af76b728f47404.tar.gz
mpd-e0e92e050e2de04ec92f782fc5af76b728f47404.tar.xz
mpd-e0e92e050e2de04ec92f782fc5af76b728f47404.zip
test: added decoder test program
Added a command line program which runs a decoder plugin.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 17eb49eb9..fee0b18fc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -502,7 +502,24 @@ sparse-check:
if ENABLE_TEST
-noinst_PROGRAMS = test/software_volume
+noinst_PROGRAMS = \
+ test/run_decoder \
+ test/software_volume
+
+test_run_decoder_CPPFLAGS = $(AM_CPPFLAGS) \
+ $(ID3TAG_CFLAGS) \
+ $(INPUT_CFLAGS) $(DECODER_CFLAGS)
+test_run_decoder_LDADD = $(MPD_LIBS) \
+ $(ID3TAG_LIBS) \
+ $(INPUT_LIBS) $(DECODER_LIBS)
+test_run_decoder_SOURCES = test/run_decoder.c \
+ src/conf.c src/buffer2array.c src/utils.c src/log.c \
+ src/tag.c src/tag_pool.c src/tag_id3.c \
+ src/replay_gain.c \
+ src/uri.c \
+ $(ARCHIVE_SRC) \
+ $(INPUT_SRC) \
+ $(DECODER_SRC)
test_software_volume_SOURCES = test/software_volume.c \
src/audio_parser.c \