aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-01-10 10:14:29 +0100
committerMax Kellermann <max@duempel.org>2013-01-10 10:23:20 +0100
commit33ba2886220a03883417c45b680606c3866dcfe7 (patch)
tree8b3a4c8ebd55d66a493919b7a4ce7d12da365791 /Makefile.am
parentd5516dee005075a7569890c0cea4235659687ea1 (diff)
downloadmpd-33ba2886220a03883417c45b680606c3866dcfe7.tar.gz
mpd-33ba2886220a03883417c45b680606c3866dcfe7.tar.xz
mpd-33ba2886220a03883417c45b680606c3866dcfe7.zip
input/{curl,soup}: convert to C++
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 82ad53ecc..cb4def839 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -82,7 +82,6 @@ mpd_headers = \
src/input_stream.h \
src/input/file_input_plugin.h \
src/input/ffmpeg_input_plugin.h \
- src/input/curl_input_plugin.h \
src/input/rewind_input_plugin.h \
src/input/mms_input_plugin.h \
src/input/despotify_input_plugin.h \
@@ -731,14 +730,14 @@ INPUT_LIBS = \
$(MMS_LIBS)
if ENABLE_CURL
-libinput_a_SOURCES += src/input/curl_input_plugin.c \
+libinput_a_SOURCES += \
+ src/input/CurlInputPlugin.cxx src/input/CurlInputPlugin.hxx \
src/icy_metadata.c
endif
if ENABLE_SOUP
libinput_a_SOURCES += \
- src/input/soup_input_plugin.c \
- src/input/soup_input_plugin.h
+ src/input/SoupInputPlugin.cxx src/input/SoupInputPlugin.hxx
endif
if ENABLE_CDIO_PARANOIA