aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-01-10 10:15:09 +0100
committerMax Kellermann <max@duempel.org>2013-01-10 10:15:09 +0100
commitd5516dee005075a7569890c0cea4235659687ea1 (patch)
tree969046fc869f266103afc06bd2e8e1bd9c201d33 /Makefile.am
parent06e0741a5293b1db2ef5f2b5778e3669f2dea70e (diff)
downloadmpd-d5516dee005075a7569890c0cea4235659687ea1.tar.gz
mpd-d5516dee005075a7569890c0cea4235659687ea1.tar.xz
mpd-d5516dee005075a7569890c0cea4235659687ea1.zip
input_stream: convert to C++ (internally)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 6 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 9b679f456..82ad53ecc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -78,9 +78,7 @@ mpd_headers = \
src/gcc.h \
src/decoder_list.h \
src/decoder/pcm_decoder_plugin.h \
- src/input_init.h \
src/input_plugin.h \
- src/input_registry.h \
src/input_stream.h \
src/input/file_input_plugin.h \
src/input/ffmpeg_input_plugin.h \
@@ -708,9 +706,9 @@ endif
#
libinput_a_SOURCES = \
- src/input_init.c \
- src/input_registry.c \
- src/input_stream.c \
+ src/InputInit.cxx src/InputInit.hxx \
+ src/InputRegistry.cxx src/InputRegistry.hxx \
+ src/InputStream.cxx \
src/input_internal.c src/input_internal.h \
src/input/rewind_input_plugin.c \
src/input/file_input_plugin.c
@@ -1078,7 +1076,7 @@ test_dump_text_file_LDADD = \
$(INPUT_LIBS) \
$(ARCHIVE_LIBS) \
$(GLIB_LIBS)
-test_dump_text_file_SOURCES = test/dump_text_file.c \
+test_dump_text_file_SOURCES = test/dump_text_file.cxx \
test/stdbin.h \
src/io_thread.c src/io_thread.h \
src/conf.c src/tokenizer.c src/utils.c src/string_util.c\
@@ -1122,7 +1120,7 @@ test_run_decoder_LDADD = \
$(TAG_LIBS) \
libutil.a \
$(GLIB_LIBS)
-test_run_decoder_SOURCES = test/run_decoder.c \
+test_run_decoder_SOURCES = test/run_decoder.cxx \
test/stdbin.h \
src/io_thread.c src/io_thread.h \
src/conf.c src/tokenizer.c src/utils.c src/string_util.c \
@@ -1145,7 +1143,7 @@ test_read_tags_LDADD = \
$(TAG_LIBS) \
libutil.a \
$(GLIB_LIBS)
-test_read_tags_SOURCES = test/read_tags.c \
+test_read_tags_SOURCES = test/read_tags.cxx \
src/io_thread.c src/io_thread.h \
src/conf.c src/tokenizer.c src/utils.c src/string_util.c \
src/Tag.cxx src/TagNames.c src/TagPool.cxx src/tag_handler.c \