aboutsummaryrefslogtreecommitdiffstats
path: root/cmake/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'cmake/src/CMakeLists.txt')
-rw-r--r--cmake/src/CMakeLists.txt12
1 files changed, 9 insertions, 3 deletions
diff --git a/cmake/src/CMakeLists.txt b/cmake/src/CMakeLists.txt
index 1e920936..08a08197 100644
--- a/cmake/src/CMakeLists.txt
+++ b/cmake/src/CMakeLists.txt
@@ -10,6 +10,12 @@ add_subdirectory(lib)
pascal_configure_file(${CMAKE_CURRENT_SOURCE_DIR}/config.inc.in
${CMAKE_CURRENT_BINARY_DIR}/config-${FPC_PLATFORM}.inc)
+# To conform to the GNU Coding Standards, INSTALL_DATADIR is
+# not hardcoded at configure-time so $prefix and $datadir can be
+# changed at make-time.
+# Paths cannot be passed to fpc via -d as with gcc's -D parameter.
+# We use an intermediate file instead.
+# See [info autoconf], "19.5 How Do I `#define' Installation Directories?"
file(WRITE ${CMAKE_CURRENT_BINARY_DIR}/paths.inc
"INSTALL_DATADIR = '${CMAKE_INSTALL_PREFIX}/share/ultrastardx';")
@@ -30,11 +36,11 @@ if(libprojectM_USE_CWRAPPER)
endif(libprojectM_USE_CWRAPPER)
pascal_add_module(ultrastardx ultrastardx.dpr
- #FLAGS -vut
- OUTPUT_DIR ${CMAKE_CURRENT_BINARY_DIR}/../game
+ #FPC_FLAGS -Si -Cs2000000 # maybe set stack size?
+ OUTPUT_DIR ${USDX_GAME_DIR}
UNITS
base/*.pas
- #macosx/*.pas
+ macosx/*.pas
media/*.pas
menu/*.pas
screens/*.pas