aboutsummaryrefslogtreecommitdiffstats
path: root/dists/gentoo/ultrastardx-1.1_alpha.ebuild
diff options
context:
space:
mode:
authortobigun <tobigun@b956fd51-792f-4845-bead-9b4dfca2ff2c>2010-04-30 20:38:19 +0000
committertobigun <tobigun@b956fd51-792f-4845-bead-9b4dfca2ff2c>2010-04-30 20:38:19 +0000
commit01060a707820907091de02348cabe193ae1ae3dd (patch)
treefdf07fc7de14bcbf4c42238c9d946727daa2fe96 /dists/gentoo/ultrastardx-1.1_alpha.ebuild
parent9dde1d580a2126b89396b88cf2a8a136da00b758 (diff)
downloadusdx-01060a707820907091de02348cabe193ae1ae3dd.tar.gz
usdx-01060a707820907091de02348cabe193ae1ae3dd.tar.xz
usdx-01060a707820907091de02348cabe193ae1ae3dd.zip
- configure recreated with autogen.sh
- cleanup git-svn-id: svn://svn.code.sf.net/p/ultrastardx/svn/trunk@2323 b956fd51-792f-4845-bead-9b4dfca2ff2c
Diffstat (limited to 'dists/gentoo/ultrastardx-1.1_alpha.ebuild')
-rw-r--r--dists/gentoo/ultrastardx-1.1_alpha.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/dists/gentoo/ultrastardx-1.1_alpha.ebuild b/dists/gentoo/ultrastardx-1.1_alpha.ebuild
deleted file mode 100644
index 7170fcdb..00000000
--- a/dists/gentoo/ultrastardx-1.1_alpha.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header $
-
-inherit eutils games
-
-SONGS_PKG=USDX-SongPackage
-SONGS_VER=01
-
-DESCRIPTION="An open-source karaoke game"
-HOMEPAGE="http://www.ultrastardeluxe.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz
- songs? ( mirror://sourceforge/${PN}/${SONGS_PKG}-${SONGS_VER}.zip )"
-
-LICENSE="GPL-2
- songs? (
- CCPL-Attribution-ShareAlike-NonCommercial-2.5
- CCPL-Attribution-NonCommercial-NoDerivs-2.5
- )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="projectm debug songs"
-
-RDEPEND="virtual/opengl
- virtual/glu
- media-libs/libsdl
- media-libs/sdl-image
- media-libs/freetype
- media-libs/libpng
- =media-libs/portaudio-19*
- media-video/ffmpeg
- dev-db/sqlite
- projectm? ( media-libs/libprojectm )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- >=dev-lang/fpc-2.2.0"
-
-S=${WORKDIR}/${P}-src
-
-pkg_setup() {
- games_pkg_setup
- built_with_use media-libs/libsdl opengl \
- || die "You need to compile media-libs/libsdl with USE=opengl."
-}
-
-src_compile() {
- egamesconf \
- $(use_with projectm libprojectM) \
- $(use_enable debug) \
- || die
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- if use songs; then
- insinto "${GAMES_DATADIR}"/${PN}/songs
- doins -r ${WORKDIR}/Songs/* || die "doins songs failed"
- fi
-
- dodoc AUTHORS.txt ChangeLog.german.txt ChangeLog.txt README.txt
-
- doicon icons/${PN}-icon.svg
- make_desktop_entry ${PN} "UltraStar Deluxe"
-
- prepgamesdirs
-}