aboutsummaryrefslogtreecommitdiffstats
path: root/net-libs/npm/npm-1.0.105.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/npm/npm-1.0.105.ebuild')
-rw-r--r--net-libs/npm/npm-1.0.105.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/net-libs/npm/npm-1.0.105.ebuild b/net-libs/npm/npm-1.0.105.ebuild
deleted file mode 100644
index ef9ff0b..0000000
--- a/net-libs/npm/npm-1.0.105.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-inherit eutils
-
-DESCRIPTION="A package manager for nodejs."
-HOMEPAGE="http://npmjs.org"
-SRC_URI="http://registry.npmjs.org/npm/-/${P}.tgz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc"
-
-DEPEND=""
-RDEPEND="${DEPEND} net-libs/nodejs"
-
-S="${WORKDIR}/package"
-
-src_configure() {
- econf --prefix="${D}usr/" || die
-}
-
-src_install() {
- emake DESTDIR="${D}usr/" install || die
-
- # remove doc directories form wrong pathq
- rm -rf "${D}usr/lib/node_modules/npm/doc/"
- rm -rf "${D}usr/lib/node_modules/npm/html/"
-
- dodoc README.md CHANGES AUTHORS || die
- if use doc ; then
- # install doc and api html pages
- dodoc -r html/doc/ || die
- dodoc -r html/api/ || die
- fi
-
- # fix npm paths
- sed -i "s~${D}usr~@PREFIX@~" "${D}usr/lib/node_modules/npm/npmrc"
-}
-
-pkg_postinst() {
- #fix npm paths
- sed -i "s~@PREFIX@~${ROOT}usr/~" "${ROOT}usr/lib/node_modules/npm/npmrc"
-}