aboutsummaryrefslogtreecommitdiffstats
path: root/www-apache/mod_h264_streaming/mod_h264_streaming-2.2.5.ebuild
diff options
context:
space:
mode:
authorAlexander Sulfrian <alexander@sulfrian.net>2010-01-06 21:45:24 +0100
committerAlexander Sulfrian <alexander@sulfrian.net>2010-01-06 21:51:04 +0100
commit0d077b6b8fdd152e12407e72cbab6b1d612fa725 (patch)
treefc92324473ed181d159529d50e44b3a9a9990cd5 /www-apache/mod_h264_streaming/mod_h264_streaming-2.2.5.ebuild
downloadoverlay-0d077b6b8fdd152e12407e72cbab6b1d612fa725.tar.gz
overlay-0d077b6b8fdd152e12407e72cbab6b1d612fa725.tar.xz
overlay-0d077b6b8fdd152e12407e72cbab6b1d612fa725.zip
initial commit
initial commit with ebuild for h264 streaming plugin for apache
Diffstat (limited to 'www-apache/mod_h264_streaming/mod_h264_streaming-2.2.5.ebuild')
-rw-r--r--www-apache/mod_h264_streaming/mod_h264_streaming-2.2.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/www-apache/mod_h264_streaming/mod_h264_streaming-2.2.5.ebuild b/www-apache/mod_h264_streaming/mod_h264_streaming-2.2.5.ebuild
new file mode 100644
index 0000000..89ea04a
--- /dev/null
+++ b/www-apache/mod_h264_streaming/mod_h264_streaming-2.2.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header$
+
+inherit apache-module
+
+DESCRIPTION="h264 streaming module plugin for apache to be able to timeshift a h264 movie during streaming"
+HOMEPAGE="http://h264.code-shop.com/"
+SRC_URI="http://h264.code-shop.com/download/apache_${P}.tar.gz"
+
+LICENSE="by-nc-sa-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+APACHE2_MOD_CONF="99_${PN}"
+APACHE2_MOD_DEFINE="H264_STREAMING"
+
+need_apache2
+
+src_compile() {
+ if [ -x ./configure ]; then
+ econf
+ fi
+ if [ -f Makefile ] || [ -f GNUmakefile ] || [ -f makefile ]; then
+ emake || die "emake failed"
+ fi
+}