aboutsummaryrefslogtreecommitdiffstats
path: root/sys-power/acpi-fakekey/acpi-fakekey-0.140.ebuild
diff options
context:
space:
mode:
authorAlexander Sulfrian <alexander@sulfrian.net>2015-05-31 15:44:33 +0200
committerAlexander Sulfrian <alexander@sulfrian.net>2015-05-31 15:44:33 +0200
commit5569badb2597966e6ae4d437a890269982a38421 (patch)
tree585563aa1bfa2c15baecb90569f8fb7750c2ea84 /sys-power/acpi-fakekey/acpi-fakekey-0.140.ebuild
parent2dd556f2db709638d47749f2b09e06b258b0f4b0 (diff)
downloadoverlay-5569badb2597966e6ae4d437a890269982a38421.tar.gz
overlay-5569badb2597966e6ae4d437a890269982a38421.tar.xz
overlay-5569badb2597966e6ae4d437a890269982a38421.zip
sys-power/acpi-fakekey: Add script to generate key events from acpi scripts
Diffstat (limited to 'sys-power/acpi-fakekey/acpi-fakekey-0.140.ebuild')
-rw-r--r--sys-power/acpi-fakekey/acpi-fakekey-0.140.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-power/acpi-fakekey/acpi-fakekey-0.140.ebuild b/sys-power/acpi-fakekey/acpi-fakekey-0.140.ebuild
new file mode 100644
index 0000000..16891ee
--- /dev/null
+++ b/sys-power/acpi-fakekey/acpi-fakekey-0.140.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="Script from Ubuntu to create key events from acpi scripts"
+HOMEPAGE="http://packages.ubuntu.com/feisty/admin/acpi-support"
+SRC_URI="mirror://ubuntu/pool/main/a/acpi-support/acpi-support_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-apps/kbd"
+S="${WORKDIR}/acpi-support-${PV}"
+
+src_compile() {
+ cd "$S"
+ sed -i 's/strip acpi_fakekey//' Makefile
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin acpi_fakekey
+
+ insinto /usr/share/${PN}
+ doins key-constants
+}