aboutsummaryrefslogtreecommitdiffstats
path: root/sys-fs/unyaffs/unyaffs-0.1.ebuild
diff options
context:
space:
mode:
authorAlexander Sulfrian <alexander@sulfrian.net>2010-09-25 11:26:39 +0200
committerAlexander Sulfrian <alexander@sulfrian.net>2010-09-25 11:26:39 +0200
commit116b84783fd6e13dbd9414ae982e48982a4a0f59 (patch)
treec839aa84efdbe928d8313715aeae77403b8340c7 /sys-fs/unyaffs/unyaffs-0.1.ebuild
parente88dea9042c4f398fdb3690b0cb7489459bbb8d7 (diff)
parent9823258f3e034315b2181d7bb37cf637b4a2c2d4 (diff)
downloadoverlay-116b84783fd6e13dbd9414ae982e48982a4a0f59.tar.gz
overlay-116b84783fd6e13dbd9414ae982e48982a4a0f59.tar.xz
overlay-116b84783fd6e13dbd9414ae982e48982a4a0f59.zip
Merge branch 'master' of ssh://git.animux.de/overlay
Diffstat (limited to 'sys-fs/unyaffs/unyaffs-0.1.ebuild')
-rw-r--r--sys-fs/unyaffs/unyaffs-0.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-fs/unyaffs/unyaffs-0.1.ebuild b/sys-fs/unyaffs/unyaffs-0.1.ebuild
new file mode 100644
index 0000000..ee4f29d
--- /dev/null
+++ b/sys-fs/unyaffs/unyaffs-0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit toolchain-funcs
+
+DESCRIPTION="a program to extract files from a yaffs image"
+HOMEPAGE="http://code.google.com/p/unyaffs/"
+SRC_URI="http://unyaffs.googlecode.com/files/unyaffs.c
+ http://unyaffs.googlecode.com/files/unyaffs.h"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+SLOT="0"
+
+DEPENDS=""
+RDEPENDS=""
+
+src_unpack() {
+ for source in ${A} ; do
+ cp ${DISTDIR}/${source} ${WORKDIR}
+ done
+}
+
+src_compile() {
+ $(tc-getCC) ${LDFLAGS} ${CFLAGS} -o ${PN} ${PN}.c || die
+}
+
+src_install() {
+ dobin ${PN}
+}