aboutsummaryrefslogtreecommitdiffstats
path: root/games-util/wbfs_file/wbfs_file-2.9.ebuild
diff options
context:
space:
mode:
authorAlexander Sulfrian <alexander@sulfrian.net>2012-03-02 18:30:17 +0100
committerAlexander Sulfrian <alexander@sulfrian.net>2012-03-02 18:30:17 +0100
commit32dc809a73102a10e336dc70dfc60dd44d18c323 (patch)
tree2bcbb0d32c2151d57db02019d8ac0fccb1261f74 /games-util/wbfs_file/wbfs_file-2.9.ebuild
parentb477a3f4d3c2aea591684ee880b0deb414070244 (diff)
downloadoverlay-32dc809a73102a10e336dc70dfc60dd44d18c323.tar.gz
overlay-32dc809a73102a10e336dc70dfc60dd44d18c323.tar.xz
overlay-32dc809a73102a10e336dc70dfc60dd44d18c323.zip
game-util/wbfs_file: added ebuild
ebuild is based on this version http://files.hboeck.de/wbfs_file-2.9.ebuild added static useflag and dependency on openssl with static-libs if enabled
Diffstat (limited to 'games-util/wbfs_file/wbfs_file-2.9.ebuild')
-rw-r--r--games-util/wbfs_file/wbfs_file-2.9.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-util/wbfs_file/wbfs_file-2.9.ebuild b/games-util/wbfs_file/wbfs_file-2.9.ebuild
new file mode 100644
index 0000000..f79d7e3
--- /dev/null
+++ b/games-util/wbfs_file/wbfs_file-2.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="wbfs_file binary for working with wbfs files or partitions"
+HOMEPAGE="http://cfg-loader.googlecode.com"
+LICENSE="GPL-2"
+SLOT="0"
+
+MY_P="${PN}_${PV}"
+SRC_URI="http://cfg-loader.googlecode.com/files/${MY_P}.zip"
+
+KEYWORDS="~amd64"
+
+IUSE="-static"
+
+DEPEND="dev-libs/openssl
+ static? ( dev-libs/openssl[static-libs] )"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}/source"
+
+src_prepare() {
+ use static || sed -i '/ADD_LF = -static/d' ${S}/Makefile
+}
+
+src_install() {
+ dobin wbfs_file
+ dodoc ../readme.txt
+ dodoc ../readme_orig.txt
+}