aboutsummaryrefslogtreecommitdiffstats
path: root/games-util/wbfs_file/wbfs_file-2.9-r2.ebuild
diff options
context:
space:
mode:
authorAlexander Sulfrian <alexander@sulfrian.net>2012-03-06 23:21:19 +0100
committerAlexander Sulfrian <alexander@sulfrian.net>2012-03-06 23:30:31 +0100
commit2d101f80f8a893c6fce63bf1cb5225219e9d82c1 (patch)
tree1a3635cf57c020f63c75a3788d94cd2e8548eaf4 /games-util/wbfs_file/wbfs_file-2.9-r2.ebuild
parentd30069f48c7ec183ebc60077bdf4fcf887dab0ac (diff)
downloadoverlay-2d101f80f8a893c6fce63bf1cb5225219e9d82c1.tar.gz
overlay-2d101f80f8a893c6fce63bf1cb5225219e9d82c1.tar.xz
overlay-2d101f80f8a893c6fce63bf1cb5225219e9d82c1.zip
games-util/wbfs_file: added patch to remove openssl deps
Diffstat (limited to 'games-util/wbfs_file/wbfs_file-2.9-r2.ebuild')
-rw-r--r--games-util/wbfs_file/wbfs_file-2.9-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-util/wbfs_file/wbfs_file-2.9-r2.ebuild b/games-util/wbfs_file/wbfs_file-2.9-r2.ebuild
new file mode 100644
index 0000000..bc48d39
--- /dev/null
+++ b/games-util/wbfs_file/wbfs_file-2.9-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="wbfs_file binary for working with wbfs files or partitions"
+HOMEPAGE="http://cfg-loader.googlecode.com"
+LICENSE="GPL-2"
+SLOT="0"
+
+MY_P="${PN}_${PV}"
+SRC_URI="http://cfg-loader.googlecode.com/files/${MY_P}.zip"
+
+KEYWORDS="~x86 ~amd64"
+
+IUSE="-static"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}/source"
+
+src_prepare() {
+ use static || sed -i '/ADD_LF = -static/d' ${S}/Makefile
+ use amd64 && epatch "${FILESDIR}/64bit_fix.patch"
+
+ sed -i 's/-lcrypto//' ${S}/Makefile
+ epatch "${FILESDIR}/no-openssl.patch"
+}
+
+src_install() {
+ dobin wbfs_file
+ dodoc ../readme.txt
+ dodoc ../readme_orig.txt
+}