aboutsummaryrefslogtreecommitdiffstats
path: root/dev-util/nfcutils/nfcutils-9999.ebuild
diff options
context:
space:
mode:
authorAlexander Sulfrian <alexander@sulfrian.net>2012-06-06 16:16:23 +0200
committerAlexander Sulfrian <alexander@sulfrian.net>2012-06-06 16:16:23 +0200
commitbd4e0540a41a5105103c57433ca72f1e247e0886 (patch)
tree7bd9751ae193d51a524b264f3773cc4e71d5a9fa /dev-util/nfcutils/nfcutils-9999.ebuild
parent09607019fae85743dd54a0b343ce44ef677994ab (diff)
downloadoverlay-bd4e0540a41a5105103c57433ca72f1e247e0886.tar.gz
overlay-bd4e0540a41a5105103c57433ca72f1e247e0886.tar.xz
overlay-bd4e0540a41a5105103c57433ca72f1e247e0886.zip
dev-util/nfcutils: add nfcutils from nfc-tools package
Diffstat (limited to 'dev-util/nfcutils/nfcutils-9999.ebuild')
-rw-r--r--dev-util/nfcutils/nfcutils-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/nfcutils/nfcutils-9999.ebuild b/dev-util/nfcutils/nfcutils-9999.ebuild
new file mode 100644
index 0000000..a8bebbe
--- /dev/null
+++ b/dev-util/nfcutils/nfcutils-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils subversion autotools
+
+DESCRIPTION="provide a simple 'lsnfc' command"
+HOMEPAGE="http://code.google.com/p/nfc-tools/"
+ESVN_REPO_URI="http://nfc-tools.googlecode.com/svn/trunk/nfcutils/"
+ESVN_PROJECT="nfcutils"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+CDEPEND=">=dev-libs/libnfc-1.5.1"
+RDEPEND="${CDEPEND}"
+
+src_prepare() {
+ eautoreconf || die "autoreconf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc README ChangeLog AUTHORS NEWS || die
+}