aboutsummaryrefslogtreecommitdiffstats
path: root/app-admin/shellinabox/shellinabox-2.10.ebuild
diff options
context:
space:
mode:
authorAlexander Sulfrian <alexander@sulfrian.net>2011-09-08 21:35:08 +0200
committerAlexander Sulfrian <alexander@sulfrian.net>2011-09-08 21:35:08 +0200
commitccf91f5b973e5433ba94dd02de35600513a750de (patch)
tree3ca9075cdcb3d40a682ce567bd57e05601337913 /app-admin/shellinabox/shellinabox-2.10.ebuild
parent7d0b31af62ca1e4c10554f6906424f62b70c50fb (diff)
downloadoverlay-ccf91f5b973e5433ba94dd02de35600513a750de.tar.gz
overlay-ccf91f5b973e5433ba94dd02de35600513a750de.tar.xz
overlay-ccf91f5b973e5433ba94dd02de35600513a750de.zip
app-admin/shellinabox: added ebuild
Diffstat (limited to 'app-admin/shellinabox/shellinabox-2.10.ebuild')
-rw-r--r--app-admin/shellinabox/shellinabox-2.10.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-admin/shellinabox/shellinabox-2.10.ebuild b/app-admin/shellinabox/shellinabox-2.10.ebuild
new file mode 100644
index 0000000..850189d
--- /dev/null
+++ b/app-admin/shellinabox/shellinabox-2.10.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header$
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Web based AJAX terminal emulator"
+HOMEPAGE="http://code.google.com/p/shellinabox"
+SRC_URI="http://shellinabox.googlecode.com/files/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2.0"
+KEYWORDS="~x86 ~amd64"
+
+IUSE="+ssl"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.8 )"
+DEPEND="${RDEPEND}"
+
+pkg_setup()
+{
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 "${PN}"
+}
+
+src_configure()
+{
+ econf \
+ $(use_enable ssl) \
+ || die "econf failed"
+}
+
+src_install()
+{
+ emake DESTDIR="${D}" install || die "einstall failed"
+
+ dodir "/var/lib/${PN}"
+ fowners ${PN}:${PN} "/var/lib/${PN}"
+
+ newinitd "${FILESDIR}"/${PN}-init ${PN}
+ newconfd "${FILESDIR}"/${PN}-conf ${PN}
+}
+