aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6e7b8d948..f36ea5483 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -180,18 +180,24 @@ mpd_SOURCES = \
stats.c \
tag.c \
tag_pool.c \
- tag_id3.c \
tag_print.c \
tag_save.c \
strset.c \
utils.c \
volume.c \
utf8.c \
- zeroconf.c \
locate.c \
storedPlaylist.c \
timer.c
+if HAVE_ID3TAG
+mpd_SOURCES += tag_id3.c
+endif
+
+if HAVE_ZEROCONF
+mpd_SOURCES += zeroconf.c
+endif
+
mpd_CFLAGS = $(MPD_CFLAGS)
mpd_CPPFLAGS = \