aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-10-17 21:13:23 +0200
committerMax Kellermann <max@duempel.org>2008-10-17 21:13:23 +0200
commit25b5d90e448146b6efaf4926680e35aee4a0af6c (patch)
tree6567bb91758598aa4214bd1939c78487806456a9 /src/Makefile.am
parent4984639b7255d72e272f278c95adb1a2cf71b61c (diff)
downloadmpd-25b5d90e448146b6efaf4926680e35aee4a0af6c.tar.gz
mpd-25b5d90e448146b6efaf4926680e35aee4a0af6c.tar.xz
mpd-25b5d90e448146b6efaf4926680e35aee4a0af6c.zip
Makefile.am: don't compile disabled sources
If a feature is disabled, don't compile the source file at all, disable it completely in Makefile.am instead.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6e7b8d948..f36ea5483 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -180,18 +180,24 @@ mpd_SOURCES = \
stats.c \
tag.c \
tag_pool.c \
- tag_id3.c \
tag_print.c \
tag_save.c \
strset.c \
utils.c \
volume.c \
utf8.c \
- zeroconf.c \
locate.c \
storedPlaylist.c \
timer.c
+if HAVE_ID3TAG
+mpd_SOURCES += tag_id3.c
+endif
+
+if HAVE_ZEROCONF
+mpd_SOURCES += zeroconf.c
+endif
+
mpd_CFLAGS = $(MPD_CFLAGS)
mpd_CPPFLAGS = \