aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 45bff8948..583659426 100644
--- a/configure.ac
+++ b/configure.ac
@@ -766,6 +766,12 @@ if test x$enable_flac = xyes; then
fi
CFLAGS="$oldcflags"
LIBS="$oldlibs"
+
+ if test x$enable_oggflac = xflac; then
+ PKG_CHECK_MODULES(OGG, [ogg], FLAC_LIBS="${FLAC_LIBS} -logg",
+ enable_oggflac=yes;
+ AC_MSG_WARN("FLAC has the ogg API built in, but couldn't find ogg. Disabling oggflac."))
+ fi
fi
AM_CONDITIONAL(HAVE_FLAC, test x$enable_flac = xyes)