aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2010-04-22 19:10:37 -0700
committerAvuton Olrich <avuton@gmail.com>2010-04-22 19:56:23 -0700
commitf4f4a908bbc8c128e6383e9f45124dce83b1c391 (patch)
treeb6857ab9762c3ed3cb4dda3ac05b8cc0a4112f80 /configure.ac
parent7c37f2879b695e6dcfcc6efbf4f8e83be87dc425 (diff)
downloadmpd-f4f4a908bbc8c128e6383e9f45124dce83b1c391.tar.gz
mpd-f4f4a908bbc8c128e6383e9f45124dce83b1c391.tar.xz
mpd-f4f4a908bbc8c128e6383e9f45124dce83b1c391.zip
configure.ac: When compiling FLAC with ogg API, linking with ogg is mandatory.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 45bff8948..583659426 100644
--- a/configure.ac
+++ b/configure.ac
@@ -766,6 +766,12 @@ if test x$enable_flac = xyes; then
fi
CFLAGS="$oldcflags"
LIBS="$oldlibs"
+
+ if test x$enable_oggflac = xflac; then
+ PKG_CHECK_MODULES(OGG, [ogg], FLAC_LIBS="${FLAC_LIBS} -logg",
+ enable_oggflac=yes;
+ AC_MSG_WARN("FLAC has the ogg API built in, but couldn't find ogg. Disabling oggflac."))
+ fi
fi
AM_CONDITIONAL(HAVE_FLAC, test x$enable_flac = xyes)