aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 177ef21c4..557ce97cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -568,6 +568,16 @@ AC_ARG_ENABLE(shout-mp3,
[disable support for mp3 streaming through shout (default: enable)]),,
[enable_shout_mp3=yes])
+AC_ARG_ENABLE(httpd-output,
+ AS_HELP_STRING([--enable-httpd-output],
+ [enables the HTTP server output (default: disable)]),,
+ [enable_httpd_output=no])
+
+AM_CONDITIONAL(ENABLE_HTTPD_OUTPUT, test x$enable_httpd_output = xyes)
+if test x$enable_httpd_output = xyes; then
+ AC_DEFINE(ENABLE_HTTPD_OUTPUT, 1, [Define to enable the HTTP server output])
+fi
+
enable_osx=no
case "$host_os" in
darwin*)
@@ -1155,6 +1165,12 @@ else
echo " SHOUTcast support .............disabled"
fi
+if test x$enable_httpd_output = xyes; then
+ echo " HTTP daemon support ...........enabled"
+else
+ echo " HTTP daemon support ...........disabled"
+fi
+
echo ""
if