aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-03-15 03:32:34 +0100
committerMax Kellermann <max@duempel.org>2009-03-15 03:32:34 +0100
commite62580db0bab0650f088f9f45c66657d18dfb679 (patch)
tree19c0deec7b75ea7fe2513c674c7de3fe2647fa7c /configure.ac
parent565afefc66b7753ed27f6b7febaf32667c38c44a (diff)
downloadmpd-e62580db0bab0650f088f9f45c66657d18dfb679.tar.gz
mpd-e62580db0bab0650f088f9f45c66657d18dfb679.tar.xz
mpd-e62580db0bab0650f088f9f45c66657d18dfb679.zip
httpd: new output plugin to replace "shout"
Let's get rid of the "shout" plugin, and the awfully complicated icecast daemon setup! MPD can do better if it's doing the HTTP server stuff on its own. This new plugin has several advantages: - easier to set up - only one daemon, no password settings, no mount settings - MPD controls the encoder and thus already knows the packet boundaries - icecast has to parse them - MPD doesn't bother to encode data while nobody is listening This implementation is very experimental (no header parsing, ignores request URI, no icy-metadata, ...). It should be able to suport several encoders in parallel in the future (with different bit rates, different codec, ...), to make MPD the perfect streaming server. Once MPD gets multi-player support, we can even mount several different radio stations on one server.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 177ef21c4..557ce97cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -568,6 +568,16 @@ AC_ARG_ENABLE(shout-mp3,
[disable support for mp3 streaming through shout (default: enable)]),,
[enable_shout_mp3=yes])
+AC_ARG_ENABLE(httpd-output,
+ AS_HELP_STRING([--enable-httpd-output],
+ [enables the HTTP server output (default: disable)]),,
+ [enable_httpd_output=no])
+
+AM_CONDITIONAL(ENABLE_HTTPD_OUTPUT, test x$enable_httpd_output = xyes)
+if test x$enable_httpd_output = xyes; then
+ AC_DEFINE(ENABLE_HTTPD_OUTPUT, 1, [Define to enable the HTTP server output])
+fi
+
enable_osx=no
case "$host_os" in
darwin*)
@@ -1155,6 +1165,12 @@ else
echo " SHOUTcast support .............disabled"
fi
+if test x$enable_httpd_output = xyes; then
+ echo " HTTP daemon support ...........enabled"
+else
+ echo " HTTP daemon support ...........disabled"
+fi
+
echo ""
if