aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index fa6f6c0b7..4775014c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1265,6 +1265,7 @@ if test x$enable_wave_encoder = xyes; then
[Define to enable the PCM wave encoder plugin])
fi
+dnl --------------------------- encoder plugins test --------------------------
if test x$enable_vorbis_encoder != xno ||
test x$enable_lame_encoder != xno ||
test x$enable_twolame_encoder != xno ||
@@ -1281,6 +1282,11 @@ else
fi
fi
+if test x$enable_encoder = xyes; then
+ AC_DEFINE(ENABLE_ENCODER, 1,
+ [Define to enable the encoder plugins])
+fi
+AM_CONDITIONAL(ENABLE_ENCODER, test x$enable_encoder = xyes)
if test x$enable_shout = xauto; then
# handle shout auto-detection: disable if no encoder is
@@ -1330,12 +1336,6 @@ if test x$enable_httpd_output = xyes; then
AC_DEFINE(ENABLE_HTTPD_OUTPUT, 1, [Define to enable the HTTP server output])
fi
-AM_CONDITIONAL(ENABLE_ENCODER, test x$enable_encoder = xyes)
-if test x$enable_encoder = xyes; then
- AC_DEFINE(ENABLE_ENCODER, 1,
- [Define to enable the encoder plugins])
-fi
-
dnl ---------------------------------------------------------------------------
dnl Documentation
dnl ---------------------------------------------------------------------------