aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 2 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 67945b51b..f7edd8145 100644
--- a/configure.ac
+++ b/configure.ac
@@ -324,11 +324,8 @@ AC_ARG_ENABLE(zip,
[enable zip archive support (default: disabled)]),,
enable_zip=no)
-if test x$enable_zip = xyes; then
- AC_CHECK_LIB(zzip, zzip_dir_open,
- [MPD_LIBS="$MPD_LIBS -lzzip"],
- enable_zip=no)
-fi
+MPD_AUTO_PKG(zip, ZZIP, [zziplib],
+ [libzzip archive library], [libzzip not found])
AM_CONDITIONAL(HAVE_ZIP, test x$enable_zip = xyes)
if test x$enable_zip = xyes; then