aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index d1d887d44..5f5f70a10 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1089,11 +1089,8 @@ AC_ARG_ENABLE(documentation,
if test x$enable_documentation = xyes; then
AC_PATH_PROG(XMLTO, xmlto)
- if test x$XMLTO = x; then
- AC_MSG_ERROR([xmlto not found])
- fi
-
AC_SUBST(XMLTO)
+ AM_CONDITIONAL(HAVE_XMLTO, test x$XMLTO != x)
AC_PATH_PROG(DOXYGEN, doxygen)
if test x$DOXYGEN = x; then
@@ -1101,6 +1098,8 @@ if test x$enable_documentation = xyes; then
fi
AC_SUBST(DOXYGEN)
+else
+ AM_CONDITIONAL(HAVE_XMLTO, false)
fi
AM_CONDITIONAL(ENABLE_DOCUMENTATION, test x$enable_documentation = xyes)