aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-03-01 01:26:04 +0100
committerMax Kellermann <max@duempel.org>2009-03-01 01:26:04 +0100
commitb4f84fab349525aa5a4ea364509a4d9ec9db47f4 (patch)
tree485413d82608295e1b9fb27fccc6c2c58159a122 /configure.ac
parentc4626143c91602cd89e47160e92e9e19db331f65 (diff)
downloadmpd-b4f84fab349525aa5a4ea364509a4d9ec9db47f4.tar.gz
mpd-b4f84fab349525aa5a4ea364509a4d9ec9db47f4.tar.xz
mpd-b4f84fab349525aa5a4ea364509a4d9ec9db47f4.zip
configure.ac: make "xmlto" optional
Even when --enable-documentation is passed, don't abort if "xmlto" was not found.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index d1d887d44..5f5f70a10 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1089,11 +1089,8 @@ AC_ARG_ENABLE(documentation,
if test x$enable_documentation = xyes; then
AC_PATH_PROG(XMLTO, xmlto)
- if test x$XMLTO = x; then
- AC_MSG_ERROR([xmlto not found])
- fi
-
AC_SUBST(XMLTO)
+ AM_CONDITIONAL(HAVE_XMLTO, test x$XMLTO != x)
AC_PATH_PROG(DOXYGEN, doxygen)
if test x$DOXYGEN = x; then
@@ -1101,6 +1098,8 @@ if test x$enable_documentation = xyes; then
fi
AC_SUBST(DOXYGEN)
+else
+ AM_CONDITIONAL(HAVE_XMLTO, false)
fi
AM_CONDITIONAL(ENABLE_DOCUMENTATION, test x$enable_documentation = xyes)