aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 20 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 26652075b..fa1348053 100644
--- a/configure.ac
+++ b/configure.ac
@@ -878,22 +878,7 @@ fi
AM_CONDITIONAL(HAVE_FIFO, test x$enable_fifo = xyes)
-
-
-MPD_AUTO_PKG(ao, AO, [ao],
- [libao output plugin], [libao not found])
-if test x$enable_ao = xyes; then
- AC_DEFINE(HAVE_AO, 1, [Define to play with ao])
-fi
-
-AM_CONDITIONAL(HAVE_AO, test x$enable_ao = xyes)
-
-if test x$enable_pipe_output = xyes; then
- AC_DEFINE([ENABLE_PIPE_OUTPUT], 1,
- [Define to enable support for writing audio to a pipe])
-fi
-AM_CONDITIONAL(ENABLE_PIPE_OUTPUT, test x$enable_pipe_output = xyes)
-
+dnl ----------------------------------- JACK ----------------------------------
MPD_AUTO_PKG(jack, JACK, [jack >= 0.100],
[JACK output plugin], [libjack not found])
if test x$enable_jack = xyes; then
@@ -912,6 +897,25 @@ fi
AM_CONDITIONAL(HAVE_JACK, test x$enable_jack = xyes)
+
+
+
+MPD_AUTO_PKG(ao, AO, [ao],
+ [libao output plugin], [libao not found])
+if test x$enable_ao = xyes; then
+ AC_DEFINE(HAVE_AO, 1, [Define to play with ao])
+fi
+
+AM_CONDITIONAL(HAVE_AO, test x$enable_ao = xyes)
+
+if test x$enable_pipe_output = xyes; then
+ AC_DEFINE([ENABLE_PIPE_OUTPUT], 1,
+ [Define to enable support for writing audio to a pipe])
+fi
+AM_CONDITIONAL(ENABLE_PIPE_OUTPUT, test x$enable_pipe_output = xyes)
+
+
+
MPD_AUTO_PKG(pulse, PULSE, [libpulse],
[PulseAudio output plugin], [libpulse not found])
if test x$enable_pulse = xyes; then