aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2010-04-16 20:06:10 -0700
committerAvuton Olrich <avuton@gmail.com>2010-04-21 07:10:14 -0700
commit791ddc566a49e4cde365fc4fee2b04ddf51cf664 (patch)
treee21debbb0ab2efe26a15ae329bc3ca360d1933f3 /configure.ac
parent7d2b2e371c6017321a51394c655ae5d9be2c86ff (diff)
downloadmpd-791ddc566a49e4cde365fc4fee2b04ddf51cf664.tar.gz
mpd-791ddc566a49e4cde365fc4fee2b04ddf51cf664.tar.xz
mpd-791ddc566a49e4cde365fc4fee2b04ddf51cf664.zip
configure.ac: Move JACK to Audio Output Plugins (nonstreaming), add subheader.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 20 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 26652075b..fa1348053 100644
--- a/configure.ac
+++ b/configure.ac
@@ -878,22 +878,7 @@ fi
AM_CONDITIONAL(HAVE_FIFO, test x$enable_fifo = xyes)
-
-
-MPD_AUTO_PKG(ao, AO, [ao],
- [libao output plugin], [libao not found])
-if test x$enable_ao = xyes; then
- AC_DEFINE(HAVE_AO, 1, [Define to play with ao])
-fi
-
-AM_CONDITIONAL(HAVE_AO, test x$enable_ao = xyes)
-
-if test x$enable_pipe_output = xyes; then
- AC_DEFINE([ENABLE_PIPE_OUTPUT], 1,
- [Define to enable support for writing audio to a pipe])
-fi
-AM_CONDITIONAL(ENABLE_PIPE_OUTPUT, test x$enable_pipe_output = xyes)
-
+dnl ----------------------------------- JACK ----------------------------------
MPD_AUTO_PKG(jack, JACK, [jack >= 0.100],
[JACK output plugin], [libjack not found])
if test x$enable_jack = xyes; then
@@ -912,6 +897,25 @@ fi
AM_CONDITIONAL(HAVE_JACK, test x$enable_jack = xyes)
+
+
+
+MPD_AUTO_PKG(ao, AO, [ao],
+ [libao output plugin], [libao not found])
+if test x$enable_ao = xyes; then
+ AC_DEFINE(HAVE_AO, 1, [Define to play with ao])
+fi
+
+AM_CONDITIONAL(HAVE_AO, test x$enable_ao = xyes)
+
+if test x$enable_pipe_output = xyes; then
+ AC_DEFINE([ENABLE_PIPE_OUTPUT], 1,
+ [Define to enable support for writing audio to a pipe])
+fi
+AM_CONDITIONAL(ENABLE_PIPE_OUTPUT, test x$enable_pipe_output = xyes)
+
+
+
MPD_AUTO_PKG(pulse, PULSE, [libpulse],
[PulseAudio output plugin], [libpulse not found])
if test x$enable_pulse = xyes; then