aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 0 insertions, 24 deletions
diff --git a/configure.ac b/configure.ac
index 16ce66cf4..ce9619dce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -382,11 +382,6 @@ AC_ARG_ENABLE(mikmod,
[enable the mikmod decoder (default: disable)]),,
enable_mikmod=no)
-AC_ARG_ENABLE(mp4v2,
- AS_HELP_STRING([--enable-mp4v2],
- [enable libmp4v2 decoder plugin]),,
- enable_mp4v2=auto)
-
AC_ARG_ENABLE(mpc,
AS_HELP_STRING([--enable-mpc],
[disable musepack (MPC) support (default: auto)]),,
@@ -984,24 +979,6 @@ dnl -------------------------------- libmodplug -------------------------------
MPD_ENABLE_AUTO_PKG(modplug, MODPLUG, [libmodplug],
[modplug decoder plugin], [libmodplug not found])
-dnl -------------------------------- libmp4v2 ---------------------------------
-if test x$enable_aac = xyes; then
- MPD_AUTO_LIB(mp4v2, MP4V2, mp4v2, MP4Create, [-lmp4v2], [],
- [mp4v2], [libmp4v2 not found])
-
- if test x$enable_mp4v2 = xyes; then
- AC_DEFINE(HAVE_MP4V2, 1, [Define to use libmp4v2 for MP4 decoding])
- fi
-else
- if test x$enable_mp4v2 = xyes; then
- AC_MSG_ERROR([MP4V2 requires AAC!])
- fi
-
- enable_mp4v2=no
-fi
-
-AM_CONDITIONAL(HAVE_MP4V2, test x$enable_mp4v2 = xyes)
-
dnl -------------------------------- libopus ----------------------------------
MPD_ENABLE_AUTO_PKG(opus, OPUS, [opus ogg],
[opus decoder plugin], [libopus not found])
@@ -1533,7 +1510,6 @@ printf '\n\t'
results(sndfile, [libsndfile])
results(mikmod, [MikMod])
results(modplug, [MODPLUG])
-results(mp4v2, [MP4V2])
results(mad, [MAD])
results(mpg123, [MPG123])
results(mpc, [Musepack])