aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c69b33020..cb85dd5ae 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -521,6 +521,13 @@ libfs_a_SOURCES = \
src/fs/StandardDirectory.cxx src/fs/StandardDirectory.hxx \
src/fs/CheckFile.cxx src/fs/CheckFile.hxx \
src/fs/DirectoryReader.hxx
+libfs_a_CPPFLAGS = $(AM_CPPFLAGS) $(ZLIB_CFLAGS)
+
+if HAVE_ZLIB
+libfs_a_SOURCES += \
+ src/fs/output/GzipOutputStream.cxx src/fs/output/GzipOutputStream.hxx
+FS_LIBS += $(ZLIB_LIBS)
+endif
# Storage library
@@ -1596,6 +1603,16 @@ test_visit_archive_SOURCES = test/visit_archive.cxx \
endif
+if HAVE_ZLIB
+
+noinst_PROGRAMS += test/run_gzip
+test_run_gzip_LDADD = \
+ libutil.a \
+ $(FS_LIBS)
+test_run_gzip_SOURCES = test/run_gzip.cxx
+
+endif
+
test_dump_text_file_LDADD = \
$(INPUT_LIBS) \
$(ARCHIVE_LIBS) \