aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2008-06-30 02:42:40 +0000
committerEric Wong <normalperson@yhbt.net>2008-06-30 02:42:40 +0000
commitbec08358369930d4631f472fce94f8adb31cdc6b (patch)
tree26b5f9e4261a7884ccd1af87a4718dad54c037de /src/Makefile.am
parent3a932bf3888d751f9cbf1df33800f38e6013af90 (diff)
downloadmpd-bec08358369930d4631f472fce94f8adb31cdc6b.tar.gz
mpd-bec08358369930d4631f472fce94f8adb31cdc6b.tar.xz
mpd-bec08358369930d4631f472fce94f8adb31cdc6b.zip
Add a generic ring buffer implementation
This piece of code is from the JACK Audio Connection Kit (trimmed down a bit for better readability). The vector functions now reuse the common iovec struct used by writev/readv instead of reinventing an identical but differently-named struct. From the comments: > ISO/POSIX C version of Paul Davis's lock free ringbuffer C++ code. > This is safe for the case of one read thread and one write thread. License is LGPL 2.1 or later git-svn-id: https://svn.musicpd.org/mpd/trunk@7386 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6d709c38a..9e053ef3e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -66,6 +66,7 @@ mpd_headers = \
playerData.h \
playlist.h \
replayGain.h \
+ ringbuf.h \
signal_check.h \
sig_handlers.h \
sllist.h \
@@ -122,6 +123,7 @@ mpd_SOURCES = \
playerData.c \
playlist.c \
replayGain.c \
+ ringbuf.c \
sig_handlers.c \
signal_check.c \
sllist.c \