aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-01-03 14:51:47 +0100
committerMax Kellermann <max@duempel.org>2009-01-13 23:09:19 +0100
commita0141dbe4f868413d78c94737846279124415479 (patch)
treee917b22e3eced7f9a8d9a4fa9e1121b899246a86 /src/Makefile.am
parentd93477d1369e55d76476952f30463461e47af443 (diff)
downloadmpd-a0141dbe4f868413d78c94737846279124415479.tar.gz
mpd-a0141dbe4f868413d78c94737846279124415479.tar.xz
mpd-a0141dbe4f868413d78c94737846279124415479.zip
pcm_utils: use the custom PRNG for volume dithering
Don't use libc's rand() function, because it is slow. Our own trivial linear congruential generator is good enough for dithering.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ad4ad99f3..0699be50e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -53,6 +53,7 @@ mpd_headers = \
pcm_channels.h \
pcm_resample.h \
pcm_dither.h \
+ pcm_prng.h \
permission.h \
player_thread.h \
player_control.h \