aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-09-08 11:46:04 +0200
committerEric Wong <normalperson@yhbt.net>2008-09-09 00:40:26 -0700
commit890be9ba54716ba765326228f7b34c0d1902e02b (patch)
tree43fb6da454d96e238ba9efbe696a5d68edd23bd8 /src/Makefile.am
parentdccdfce721ffe730de2f55a67ecd1acfcb19bb0a (diff)
downloadmpd-890be9ba54716ba765326228f7b34c0d1902e02b.tar.gz
mpd-890be9ba54716ba765326228f7b34c0d1902e02b.tar.xz
mpd-890be9ba54716ba765326228f7b34c0d1902e02b.zip
added string set library
"struct strset" is a hashed string set: you can add strings to this library, and it stores them as a set of unique strings. You can get the size of the set, and you can enumerate through all values. This will be used to replace the linear tagTracker library.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d8640d304..fcb313418 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -85,6 +85,7 @@ mpd_headers = \
tag_id3.h \
tagTracker.h \
utf8.h \
+ strset.h \
utils.h \
volume.h \
ioops.h \
@@ -142,6 +143,7 @@ mpd_SOURCES = \
tag_pool.c \
tag_id3.c \
tagTracker.c \
+ strset.c \
utils.c \
volume.c \
utf8.c \