aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-09-07 13:35:01 +0200
committerMax Kellermann <max@duempel.org>2008-09-07 13:35:01 +0200
commit75aa8dad4ccf1bb942c327d78b0ddad821c4abaa (patch)
tree6667baf1bd77d3fbbb9771f198057c903c6138f1 /src/Makefile.am
parent386c303121a8c53f11cc91c59bbe87f93a503b31 (diff)
downloadmpd-75aa8dad4ccf1bb942c327d78b0ddad821c4abaa.tar.gz
mpd-75aa8dad4ccf1bb942c327d78b0ddad821c4abaa.tar.xz
mpd-75aa8dad4ccf1bb942c327d78b0ddad821c4abaa.zip
song: moved code to song_print.c, song_save.c
Move everything which dumps song information (via tag_print.c) to a separate source file. song_print.c gets code which writes song data to the client; song_save.c is responsible for serializing songs from the tag cache.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2c3905414..ba7b7c3a3 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -79,6 +79,8 @@ mpd_headers = \
sig_handlers.h \
sllist.h \
song.h \
+ song_print.h \
+ song_save.h \
state_file.h \
stats.h \
tag.h \
@@ -144,6 +146,8 @@ mpd_SOURCES = \
signal_check.c \
sllist.c \
song.c \
+ song_print.c \
+ song_save.c \
state_file.c \
stats.c \
tag.c \