aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWarren Dukes <warren.dukes@gmail.com>2004-04-13 02:20:46 +0000
committerWarren Dukes <warren.dukes@gmail.com>2004-04-13 02:20:46 +0000
commit375e3ffed496c995383156f9675fa95f145e05bf (patch)
tree70fe33adf511043461fc41eb1d7b42c6145846a4 /src/Makefile.am
parent6bc445d00f7479c106828651abc3d76ddee5a5a5 (diff)
downloadmpd-375e3ffed496c995383156f9675fa95f145e05bf.tar.gz
mpd-375e3ffed496c995383156f9675fa95f145e05bf.tar.xz
mpd-375e3ffed496c995383156f9675fa95f145e05bf.zip
add my own utf8/ascii converters and utf8 validator
validate all mpd tags on import, if they are invalid, assume they are ascii and convert to utf8 git-svn-id: https://svn.musicpd.org/mpd/trunk@707 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e3d7c0144..3b6717936 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -5,13 +5,13 @@ mpd_headers = buffer2array.h interface.h command.h playlist.h ls.h \
tag.h player.h listen.h conf.h ogg_decode.h volume.h flac_decode.h \
audio.h playerData.h stats.h myfprintf.h sig_handlers.h decode.h log.h \
audiofile_decode.h charConv.h permission.h mpd_types.h pcm_utils.h \
- mp4_decode.h aac_decode.h signal_check.h
+ mp4_decode.h aac_decode.h signal_check.h utf8.h
mpd_SOURCES = main.c buffer2array.c interface.c command.c playlist.c ls.c \
song.c list.c directory.c tables.c utils.c path.c mp3_decode.c \
tag.c player.c listen.c conf.c ogg_decode.c volume.c flac_decode.c \
audio.c playerData.c stats.c myfprintf.c sig_handlers.c decode.c log.c \
audiofile_decode.c charConv.c permission.c pcm_utils.c mp4_decode.c \
- aac_decode.c signal_check.c $(mpd_headers)
+ aac_decode.c signal_check.c utf8.c $(mpd_headers)
mpd_CFLAGS = $(MPD_CFLAGS)
mpd_LDADD = $(MPD_LIBS) $(ID3_LIB) $(MAD_LIB) $(MP4FF_LIB)