aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-10-26 21:58:37 +0100
committerMax Kellermann <max@duempel.org>2008-10-26 21:58:37 +0100
commit0800c6f4ca36012b65e3cde825663adc1eafeae2 (patch)
tree5d0f24a02042c48a30d6b67920f77ef65e7e6215 /src/Makefile.am
parent3dac99034afe14e61554f327329c11d32962ae04 (diff)
downloadmpd-0800c6f4ca36012b65e3cde825663adc1eafeae2.tar.gz
mpd-0800c6f4ca36012b65e3cde825663adc1eafeae2.tar.xz
mpd-0800c6f4ca36012b65e3cde825663adc1eafeae2.zip
output: don't compile plugins which are disabled
Don't compile the sources of disabled output plugins at all.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am61
1 files changed, 46 insertions, 15 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 15d15e175..511ffac77 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,19 +1,5 @@
bin_PROGRAMS = mpd
-mpd_output = \
- output/shout_plugin.c \
- output/shout_ogg.c \
- output/shout_mp3.c \
- output/null_plugin.c \
- output/fifo_plugin.c \
- output/alsa_plugin.c \
- output/ao_plugin.c \
- output/oss_plugin.c \
- output/osx_plugin.c \
- output/pulse_plugin.c \
- output/mvp_plugin.c \
- output/jack_plugin.c
-
mpd_headers = \
notify.h \
ack.h \
@@ -102,7 +88,6 @@ mpd_headers = \
mpd_SOURCES = \
$(mpd_headers) \
- $(mpd_output) \
notify.c \
audio.c \
audioOutput.c \
@@ -111,6 +96,7 @@ mpd_SOURCES = \
output_thread.c \
output_control.c \
output_init.c \
+ output/null_plugin.c \
buffer2array.c \
command.c \
idle.c \
@@ -248,6 +234,51 @@ mpd_SOURCES += input_curl.c
endif
+if HAVE_ALSA
+mpd_SOURCES += output/alsa_plugin.c
+endif
+
+if HAVE_AO
+mpd_SOURCES += output/ao_plugin.c
+endif
+
+if HAVE_FIFO
+mpd_SOURCES += output/fifo_plugin.c
+endif
+
+if HAVE_JACK
+mpd_SOURCES += output/jack_plugin.c
+endif
+
+if HAVE_MVP
+mpd_SOURCES += output/mvp_plugin.c
+endif
+
+if HAVE_OSS
+mpd_SOURCES += output/oss_plugin.c
+endif
+
+if HAVE_OSX
+mpd_SOURCES += output/osx_plugin.c
+endif
+
+if HAVE_PULSE
+mpd_SOURCES += output/pulse_plugin.c
+endif
+
+if HAVE_SHOUT
+mpd_SOURCES += output/shout_plugin.c
+endif
+
+if HAVE_SHOUT_MP3
+mpd_SOURCES += output/shout_mp3.c
+endif
+
+if HAVE_SHOUT_OGG
+mpd_SOURCES += output/shout_ogg.c
+endif
+
+
mpd_CFLAGS = $(MPD_CFLAGS)
mpd_CPPFLAGS = \
$(CURL_CFLAGS) \