aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/hd/Makefile.am
diff options
context:
space:
mode:
authorAndreas Obergrusberger <tradiaz@yahoo.de>2007-01-03 20:12:16 +0000
committerAndreas Obergrusberger <tradiaz@yahoo.de>2007-01-03 20:12:16 +0000
commit6d9b28ec69212a2542ab2958ed0b012c124dbc07 (patch)
tree17cb3f8bb8b8a3f6e0bf824202148dc326a9f25c /plugins/hd/Makefile.am
parentb454d1517608a8f137723c6c5080bbcb29e7329c (diff)
downloadmpd-6d9b28ec69212a2542ab2958ed0b012c124dbc07.tar.gz
mpd-6d9b28ec69212a2542ab2958ed0b012c124dbc07.tar.xz
mpd-6d9b28ec69212a2542ab2958ed0b012c124dbc07.zip
added a plugin system for lyrics sources
git-svn-id: https://svn.musicpd.org/ncmpc/branches/tradiaz@5217 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'plugins/hd/Makefile.am')
-rw-r--r--plugins/hd/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/plugins/hd/Makefile.am b/plugins/hd/Makefile.am
new file mode 100644
index 000000000..f4d4608d8
--- /dev/null
+++ b/plugins/hd/Makefile.am
@@ -0,0 +1,40 @@
+AM_CPPFLAGS =\
+ $(GLIB_CFLAGS)\
+ $(GTHREAD_CFLAGS)\
+ $(libcurl_CFLAGS)\
+ -I../../src
+
+###----
+
+plugin_headers =\
+ ../src_lyrics.h\
+ ../screen_lyrics.h\
+ ../easy_download.h\
+ ../options.h
+
+###-----
+
+ncmpc_modulesdir = @plugindir@
+
+ncmpc_modules_LTLIBRARIES = libhd.la
+
+### libhd
+
+libhd_la_LIBADD =\
+ $(GLIB_LIBS)\
+ $(libcurl_LIBS)
+
+libhd_la_headers =\
+ $(plugins_headers)
+
+libhd_la_SOURCES =\
+ lyrics_hd.c\
+ $(libhd_la_headers)
+install:
+ @$(MAKE)
+ mkdir -p ${ncmpc_modulesdir}
+ if test -f .libs/libhd.so; then cp .libs/libhd.so ${ncmpc_modulesdir}/lyrics_hd.so; fi
+
+uninstall:
+ @$(MAKE)
+ rm -f ${ncmpc_modulesdir}/lyrics_hd.so