aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2010-04-17 15:20:34 -0700
committerAvuton Olrich <avuton@gmail.com>2010-04-21 12:23:38 -0700
commitf946a182a3101ae2115c23bb4841c69309663363 (patch)
treee87a3a2c6091c66dbda0811b84ab9d1e036d021f /configure.ac
parentd3fcb81da0335e852529a7df49f0520c5b126e53 (diff)
downloadmpd-f946a182a3101ae2115c23bb4841c69309663363.tar.gz
mpd-f946a182a3101ae2115c23bb4841c69309663363.tar.xz
mpd-f946a182a3101ae2115c23bb4841c69309663363.zip
configure.ac: Rewrite the liboggflac tests.
Rewrite the liboggflac tests, the m4 macro is way too complicated for no reason and it's buggy.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 3 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 8606da0d7..3e5561d42 100644
--- a/configure.ac
+++ b/configure.ac
@@ -951,16 +951,13 @@ if test x$use_tremor = xyes && test $xenable_oggflac = xyes; then
enable_oggflac=no
fi
-if test x$enable_oggflac = xyes; then
- oldmpdcflags="$MPD_CFLAGS"
- oldmpdlibs="$MPD_LIBS"
- AM_PATH_LIBOGGFLAC(MPD_LIBS="$MPD_LIBS $LIBOGGFLAC_LIBS"
- MPD_CFLAGS="$MPD_CFLAGS $LIBOGGFLAC_CFLAGS",
- enable_oggflac=no)
+if test x$enable_oggflac = xyes; then
+ AC_CHECK_HEADER([OggFLAC/stream_decoder.h],, enable_oggflac=no)
fi
if test x$enable_oggflac = xyes; then
AC_DEFINE(HAVE_OGGFLAC,1,[Define for OggFLAC support])
+ MPD_LIBS="$MPD_LIBS -lOggFLAC -lFLAC -lm"
fi
AM_CONDITIONAL(HAVE_OGGFLAC, test x$enable_oggflac = xyes)