aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-02-12 18:14:14 +0100
committerMax Kellermann <max@duempel.org>2009-02-12 18:14:14 +0100
commitf6c8dd49617b411a25c095710e43ba3b4725f55c (patch)
tree20053412f7769e23df0b3d20cc56fef2ca432cd2 /configure.ac
parent321eb1077a54aa84dca2f6363fe776af4f489689 (diff)
downloadmpd-f6c8dd49617b411a25c095710e43ba3b4725f55c.tar.gz
mpd-f6c8dd49617b411a25c095710e43ba3b4725f55c.tar.xz
mpd-f6c8dd49617b411a25c095710e43ba3b4725f55c.zip
configure.ac: always check for C++ compiler
Currently, only the sidplay decoder plugin requires C++, and in all other cases, MPD could build well without a C++ compiler. Unfortunately, autoconf/automake are confused when we have a conditional AC_PROG_CXX check. We could add lots of workarounds for individual problems, but let's just always require a C++ compiler, and forget about this autotools limitation.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 2 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 67e2cb1f6..b742677a2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,6 +13,8 @@ dnl programs
dnl
AC_PROG_CC_C99
+AC_PROG_CXX
+
AC_PROG_INSTALL
AC_PROG_MAKE_SET
PKG_PROG_PKG_CONFIG
@@ -1020,17 +1022,12 @@ fi
AM_CONDITIONAL(HAVE_FFMPEG, test x$enable_ffmpeg = xyes)
if test x$enable_sidplay = xyes; then
- # libsidplay2 exposes a C++ interface
- AC_PROG_CXX
-
# we have no test yet.. we're not using pkg-config here
# because libsidplay2's .pc file requires libtool
AC_SUBST(SIDPLAY_LIBS,"-lsidplay2 -lresid-builder")
AC_SUBST(SIDPLAY_CFLAGS,)
AC_DEFINE(ENABLE_SIDPLAY, 1, [Define for libsidplay2 support])
-else
- AM_CONDITIONAL(am__fastdepCXX, false)
fi
AM_CONDITIONAL(ENABLE_SIDPLAY, test x$enable_sidplay = xyes)