aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-03-27 19:51:59 +0100
committerMax Kellermann <max@duempel.org>2009-03-27 19:51:59 +0100
commitf5548a86543fa0cc0c0cc114240c5aef30950706 (patch)
treecb4562b4a8c9af171cc5b7994f47e75b596fbfc5 /configure.ac
parent0e18fab655f0529f8b8576a7b6c7a620aa0ad552 (diff)
downloadmpd-f5548a86543fa0cc0c0cc114240c5aef30950706.tar.gz
mpd-f5548a86543fa0cc0c0cc114240c5aef30950706.tar.xz
mpd-f5548a86543fa0cc0c0cc114240c5aef30950706.zip
mpcdec: support the new libmpcdec SV8 API
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 94e01bc0d..886ee9431 100644
--- a/configure.ac
+++ b/configure.ac
@@ -752,7 +752,11 @@ if test x$enable_mpc = xyes; then
CFLAGS="$CFLAGS $MPD_CFLAGS $MPCDEC_CFLAGS -I."
LIBS="$LIBS $MPD_LIBS $MPCDEC_LIBS"
CPPFLAGS=$CFLAGS
- AC_CHECK_HEADER(mpcdec/mpcdec.h,,enable_mpc=no)
+ AC_CHECK_HEADER(mpc/mpcdec.h,
+ old_mpcdec=no,
+ [AC_CHECK_HEADER(mpcdec/mpcdec.h,
+ old_mpcdec=yes,
+ enable_mpc=no)])
if test x$enable_mpc = xyes; then
AC_CHECK_LIB(mpcdec,main,
[MPD_LIBS="$MPD_LIBS $MPCDEC_LIBS";
@@ -762,6 +766,10 @@ if test x$enable_mpc = xyes; then
if test x$enable_mpc = xyes; then
AC_DEFINE(HAVE_MPCDEC,1,
[Define to use libmpcdec for MPC decoding])
+ if test x$old_mpcdec = xyes; then
+ AC_DEFINE(MPC_IS_OLD_API, 1,
+ [Define if an old pre-SV8 libmpcdec is used])
+ fi
else
AC_MSG_WARN([mpcdec lib needed for MPC support -- disabling MPC support])
fi