aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWarren Dukes <warren.dukes@gmail.com>2004-05-31 20:59:55 +0000
committerWarren Dukes <warren.dukes@gmail.com>2004-05-31 20:59:55 +0000
commitd9f5cca9b83831c89c8fe93c47100f86e1649fd7 (patch)
treef563b57b92b1bb17e9322615bef6b3623650f537 /configure.ac
parent2c1f5365ebbd7ffd9ffa660a39ebc052ef96e4d2 (diff)
downloadmpd-d9f5cca9b83831c89c8fe93c47100f86e1649fd7.tar.gz
mpd-d9f5cca9b83831c89c8fe93c47100f86e1649fd7.tar.xz
mpd-d9f5cca9b83831c89c8fe93c47100f86e1649fd7.zip
mod_plugin, just for tarzeau
git-svn-id: https://svn.musicpd.org/mpd/trunk@1263 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 16 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index adf35559a..e79cc5c49 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,8 +40,9 @@ AC_ARG_ENABLE(flac,[ --disable-flac disable flac support],,enable_flac=yes)
AC_ARG_ENABLE(mp3,[ --disable-mp3 disable mp3 support],,enable_mp3=yes)
AC_ARG_ENABLE(aac,[ --disable-aac disable AAC support],,enable_aac=yes)
AC_ARG_ENABLE(audiofile,[ --disable-audiofile disable audiofile support, disables wave support],,enable_audiofile=yes)
-AC_ARG_ENABLE(mpd_mad,[ --enable-mpd-mad use mpd libmad],use_mpd_mad=yes,)
+AC_ARG_ENABLE(mod,[ --disable-mod disable MOD support],,enable_mod=yes)
AC_ARG_ENABLE(id3,[ --disable-id3 disable id3 support],,enable_id3=yes)
+AC_ARG_ENABLE(mpd_mad,[ --enable-mpd-mad use mpd libmad],use_mpd_mad=yes,)
AC_ARG_ENABLE(mpd_id3tag,[ --enable-mpd-id3tag use mpd libid3tag],use_mpd_id3tag=yes,)
AC_ARG_WITH(iconv,[ --with-iconv=PFX Prefix where iconv is installed (optional)], iconv_prefix="$withval", iconv_prefix="")
@@ -473,6 +474,14 @@ if test x$enable_audiofile = xyes; then
AC_DEFINE(HAVE_AUDIOFILE,1,[Define for audiofile support])
fi
+if test x$enable_mod = xyes; then
+ AM_PATH_LIBMIKMOD(3.1.7, MPD_CFLAGS="$MPD_CFLAGS $LIBMIKMOD_CFLAGS"
+ MPD_LIBS="$MPD_LIBS $LIBMIKMOD_LIBS", enable_mod=no)
+ if test x$enable_mod = xyes; then
+ AC_DEFINE(HAVE_MIKMOD, 1, [Define for mikmod support])
+ fi
+fi
+
AC_OUTPUT(src/mp4ff/Makefile doc/Makefile src/Makefile Makefile )
echo ""
@@ -565,6 +574,12 @@ else
echo "MP4/AAC support ...............disabled"
fi
+if test x$enable_mod = xyes; then
+ echo "MOD support ...................enabled"
+else
+ echo "MOD support ...................disabled"
+fi
+
echo ""
echo "##########################################"
echo ""