aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-12-29 14:12:33 +0100
committerMax Kellermann <max@duempel.org>2013-12-29 14:12:33 +0100
commitd7f80eab68b5cb0d2aa90e67fa2bb04b1bbef975 (patch)
treed8a28a745420dee785deeb8312f07f59e6afea80 /configure.ac
parente30b356eb018adcfb3efbce97c81bc0d99934826 (diff)
downloadmpd-d7f80eab68b5cb0d2aa90e67fa2bb04b1bbef975.tar.gz
mpd-d7f80eab68b5cb0d2aa90e67fa2bb04b1bbef975.tar.xz
mpd-d7f80eab68b5cb0d2aa90e67fa2bb04b1bbef975.zip
configure.ac: improved check for libyajl 1.0
If we have libyajl 2.0.1 (without a pkg-config file), our configure.ac would assume this is the libyajl 1.0 API, because the function yajl_alloc() exists in both. This commit changes the library check to the function yajl_parse_complete() which was removed in the 2.0 API. This fixes build failure with libyajl 2.0.1.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9909cb461..b2e952808 100644
--- a/configure.ac
+++ b/configure.ac
@@ -732,7 +732,7 @@ dnl --------------------------------- Soundcloud ------------------------------
if test x$enable_soundcloud != xno; then
PKG_CHECK_MODULES([YAJL], [yajl >= 2.0],
[found_soundcloud=yes],
- AC_CHECK_LIB([yajl], [yajl_alloc],
+ AC_CHECK_LIB([yajl], [yajl_parse_complete],
[found_soundcloud=yes YAJL_CFLAGS=-DHAVE_YAJL1 YAJL_LIBS=-lyajl],
[found_soundcloud=no]))
fi