aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDenis Krjuchkov <denis@crazydev.net>2013-11-29 14:38:48 +0600
committerDenis Krjuchkov <denis@crazydev.net>2013-11-29 15:05:01 +0600
commitcfdd5edc499601430bb93a8b593fab0edec34f08 (patch)
treed93b9897694a3a9ffe27db293c7a5c4274514812 /configure.ac
parentb9035d3e0a3a413700ea87cd539b075d4f5aa764 (diff)
downloadmpd-cfdd5edc499601430bb93a8b593fab0edec34f08.tar.gz
mpd-cfdd5edc499601430bb93a8b593fab0edec34f08.tar.xz
mpd-cfdd5edc499601430bb93a8b593fab0edec34f08.zip
event: implement PollGroup based on Windows select
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 11 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index db35fc0bf..23998269b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -170,13 +170,15 @@ AC_ARG_WITH(eventloop,
AC_ARG_WITH(pollmethod,
AS_HELP_STRING(
- [--with-pollmethod=@<:@epoll|auto@:>@],
+ [--with-pollmethod=@<:@epoll|winselect|auto@:>@],
[specify poll method for internal event loop (default=auto)]),,
[with_pollmethod=auto])
if test "x$with_eventloop" = xauto; then
- if test "x$enable_epoll" = xyes; then
- with_eventloop=internal
+ if
+ test "x$enable_epoll" = xyes ||
+ test "x$host_is_windows" = xyes; then
+ with_eventloop=internal
else
with_eventloop=glib
fi
@@ -200,6 +202,8 @@ if test "x$with_eventloop" = xinternal; then
if test "x$with_pollmethod" = xauto; then
if test "x$enable_epoll" = xyes; then
with_pollmethod=epoll
+ elif test "x$host_is_windows" = xyes; then
+ with_pollmethod=winselect
else
AC_MSG_ERROR([no poll method is available for your platform])
fi
@@ -208,6 +212,10 @@ if test "x$with_eventloop" = xinternal; then
epoll)
AC_DEFINE(USE_EPOLL, 1, [Define to poll sockets with epoll])
;;
+ winselect)
+ AC_DEFINE(USE_WINSELECT, 1,
+ [Define to poll sockets with Windows select])
+ ;;
*)
AC_MSG_ERROR([unknown pollmethod option: $with_pollmethod])
esac