aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichal Nazarewicz <mina86@mina86.com>2009-02-28 16:11:59 +0100
committerMax Kellermann <max@duempel.org>2009-02-28 16:11:59 +0100
commitcabbf7ab4a97e5f173b5fd4deb3fab4e66538586 (patch)
treefa91ee1ecc4e9a5914f2e7908cd4640d7c4425ac /configure.ac
parent5ea8a0df3ff159d1c9879b4a3a4c56ff34f0e43f (diff)
downloadmpd-cabbf7ab4a97e5f173b5fd4deb3fab4e66538586.tar.gz
mpd-cabbf7ab4a97e5f173b5fd4deb3fab4e66538586.tar.xz
mpd-cabbf7ab4a97e5f173b5fd4deb3fab4e66538586.zip
pipe: new audio output plugin which runs a command
[mk: adapted to new output plugin API]
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 653bea29d..d71d3eb0f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -497,6 +497,16 @@ AC_ARG_ENABLE(fifo,
enable_fifo=$enableval,
enable_fifo=yes)
+AC_ARG_ENABLE(pipe-output,
+ AS_HELP_STRING([--enable-pipe-output],
+ [disable support for writing audio to a pipe (default: disable)]),,
+ enable_pipe_output=no)
+
+if test x$enable_pipe_output = xyes; then
+ AC_DEFINE([ENABLE_PIPE_OUTPUT], 1, [Define to enable support for writing audio to a pipe])
+fi
+AM_CONDITIONAL(ENABLE_PIPE_OUTPUT, test x$enable_pipe_output = xyes)
+
AC_ARG_ENABLE(jack,
AS_HELP_STRING([--disable-jack],
[disable jack support (default: enable)]),