aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-12-17 17:16:24 +0100
committerMax Kellermann <max@duempel.org>2008-12-17 17:16:24 +0100
commitc41fa6cf5ea637a2e62b130d65853aa727c386f7 (patch)
tree9faf88733c487d313c14a6edfdb1e34e4e3c8a2a /configure.ac
parentcaf601199b9404807ad52a38ce55c08dba8a8ba6 (diff)
downloadmpd-c41fa6cf5ea637a2e62b130d65853aa727c386f7.tar.gz
mpd-c41fa6cf5ea637a2e62b130d65853aa727c386f7.tar.xz
mpd-c41fa6cf5ea637a2e62b130d65853aa727c386f7.zip
configure.ac: check lame availability before shout_mp3 test
If lame was not available, the shout_mp3 plugin was enabled anyway, and triggered compiler errors.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 5e21bae29..cf5f679fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -356,6 +356,11 @@ if test x$enable_shout_ogg = xyes; then
fi
fi
+if test x$enable_lame = xyes; then
+ AM_PATH_LAME([MPD_LIBS="$MPD_LIBS $LAME_LIBS" MPD_CFLAGS="$MPD_CFLAGS $LAME_CFLAGS"],
+ [enable_lame=no; AC_MSG_WARN(You need lame -- disabling lame support)])
+fi
+
if test x$enable_shout_mp3 = xyes; then
if test x$enable_lame = xno; then
AC_MSG_WARN([disabling mp3 shout streaming support because lame is not enabled])
@@ -460,11 +465,6 @@ fi
AM_CONDITIONAL(HAVE_MAD, test x$enable_mp3 = xyes)
-if test x$enable_lame = xyes; then
- AM_PATH_LAME([MPD_LIBS="$MPD_LIBS $LAME_LIBS" MPD_CFLAGS="$MPD_CFLAGS $LAME_CFLAGS"],
- [enable_lame=no;AC_MSG_WARN(You need lame -- disabling lame support)])
-fi
-
if test x$enable_mpc = xyes; then
if test "x$mpcdec_libraries" != "x" ; then